// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{1,2}\/\d{1,2}\/(\d{4}|\d{2})\b").unwrap();
let string = "Bắt các chuỗi ngày tháng này
12/01/2017
15/2/2017
3/03/2018
1/1/2018
7/9/18
60/60/2018
Không bắt các chuỗi như thế này, vì không đúng ngày tháng
123/2/1234 13/ab/3346 12/223/12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}