import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(0?[1-9]|[12]\\d|3[01])[\\/\\-.](0?[1-9]|[12]\\d|3[01])[\\/\\-.](\\d{2}|\\d{4})\\b";
final String string = "Bắt các chuỗi ngày tháng này\n"
+ "12/01/2017\n"
+ "15/2/2017\n"
+ "3/03/2018\n"
+ "12/24/2018\n"
+ "1.1.2018\n"
+ "7-9-18\n"
+ "1.31.2018\n\n\n"
+ "Không bắt các chuỗi như thế này, vì không đúng ngày tháng\n"
+ "123/2/1234 13/ab/3346 12/223/12 60/60/2018 32/12/2018\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}