# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(0?[1-9]|[12]\d|3[01])[\/\-.](0?[1-9]|[12]\d|3[01])[\/\-.](\d{2}|\d{4})\b"
test_str = ("Bắt các chuỗi ngày tháng này\n"
"12/01/2017\n"
"15/2/2017\n"
"3/03/2018\n"
"12/24/2018\n"
"1.1.2018\n"
"7-9-18\n"
"1.31.2018\n\n\n"
"Không bắt các chuỗi như thế này, vì không đúng ngày tháng\n"
"123/2/1234 13/ab/3346 12/223/12 60/60/2018 32/12/2018\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.