package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%\s*Parameter|(Parameter.*)`)
var str = `Parameter: A
%Parameter: B
% Parameter: C
Parameter: D %the best parameter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}