re = /%\s*Parameter|(Parameter.*)/
str = 'Parameter: A
%Parameter: B
% Parameter: C
Parameter: D %the best parameter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end