import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.\\s+(?:(?!^\\d+\\.\\s).)*\\bthe Agency\\b(?:(?!^\\d+\\.\\s).)*";
final String string = "where sucts. \n"
+ "1. The objectives of the STh other arrangements are not inconsistent or in conflict with this licence \n"
+ "or the STC or other relevant statutory requirements. \n"
+ "3. The objectives of the STC referred to in sub-paragraph 1(c) are the:\n"
+ "(a) efficient discharge of the obligations imposed upon transmission licensees by \n"
+ "transmission licences and the Act;\n"
+ "(b) compliance with the Electricity Regulation and any relevant legally binding \n"
+ "decision of the European Commission and/or the Agency.\n"
+ "4. The STC shall provide for:\n"
+ "(a) there to be referred to the Authority for determination such matters arising under \n"
+ "the STC as may be specified in the STC; \n"
+ "(b) a copy of the STC or any part(s) thereof\n"
+ "5. We know that\n"
+ "the Agency does\n"
+ "good work.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}