const regex = /^\d+\.\s+(?:(?!^\d+\.\s).)*\bthe Agency\b(?:(?!^\d+\.\s).)*/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.\\s+(?:(?!^\\d+\\.\\s).)*\\bthe Agency\\b(?:(?!^\\d+\\.\\s).)*', 'gms')
const str = `where sucts.
1. The objectives of the STh other arrangements are not inconsistent or in conflict with this licence
or the STC or other relevant statutory requirements.
3. The objectives of the STC referred to in sub-paragraph 1(c) are the:
(a) efficient discharge of the obligations imposed upon transmission licensees by
transmission licences and the Act;
(b) compliance with the Electricity Regulation and any relevant legally binding
decision of the European Commission and/or the Agency.
4. The STC shall provide for:
(a) there to be referred to the Authority for determination such matters arising under
the STC as may be specified in the STC;
(b) a copy of the STC or any part(s) thereof
5. We know that
the Agency does
good work.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}