# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\.\s+(?:(?!^\d+\.\s).)*\bthe Agency\b(?:(?!^\d+\.\s).)*"
test_str = ("where sucts. \n"
"1. The objectives of the STh other arrangements are not inconsistent or in conflict with this licence \n"
"or the STC or other relevant statutory requirements. \n"
"3. The objectives of the STC referred to in sub-paragraph 1(c) are the:\n"
"(a) efficient discharge of the obligations imposed upon transmission licensees by \n"
"transmission licences and the Act;\n"
"(b) compliance with the Electricity Regulation and any relevant legally binding \n"
"decision of the European Commission and/or the Agency.\n"
"4. The STC shall provide for:\n"
"(a) there to be referred to the Authority for determination such matters arising under \n"
"the STC as may be specified in the STC; \n"
"(b) a copy of the STC or any part(s) thereof\n"
"5. We know that\n"
"the Agency does\n"
"good work.\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.