import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=i.s.d.n.c.)(.*)(?=\"><img)";
final String string = "37ce7aa49c fd5 .v& cs=i.s.d.n.c.rat.1.8\"><img class=\"icn centre\" src=\"pict/imti.svg\" alt=\"im";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}