const regex = /(?<=i.s.d.n.c.)(.*)(?="><img)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=i.s.d.n.c.)(.*)(?="><img)', 'gm')
const str = `37ce7aa49c fd5 .v& cs=i.s.d.n.c.rat.1.8"><img class="icn centre" src="pict/imti.svg" alt="im`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}