$re = '/(?<=i.s.d.n.c.)(.*)(?="><img)/m';
$str = '37ce7aa49c fd5 .v& cs=i.s.d.n.c.rat.1.8"><img class="icn centre" src="pict/imti.svg" alt="im';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);