#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?!apple\.)\b[A-Za-z-]*?apple[A-Za-z-]*\b(?:\.[A-Za-z]+)+$"
Local $sString = "badapple.com" & @CRLF & _
"https://fuckapple.dk" & @CRLF & _
"https://www.apple-sucks.co.uk" & @CRLF & _
"https://help.apple.com" & @CRLF & _
"support.apple.dk" & @CRLF & _
"fuck.apple.se" & @CRLF & _
"applesucks.fi" & @CRLF & _
"www.applesucks.fi" & @CRLF & _
"https://example-apple.com" & @CRLF & _
"my-apple-domain.net" & @CRLF & _
"apple-products.org" & @CRLF & _
"best-apple-deals.info" & @CRLF & _
"https://www.fresh-apple-pie.co.uk" & @CRLF & _
"juicyapplejuice.biz" & @CRLF & _
"https://apple-store-discount.ca" & @CRLF & _
"https://www.apple-store-discount.ca" & @CRLF & _
"www.apple.dk" & @CRLF & _
"apple.dk" & @CRLF & _
"https://apple.com" & @CRLF & _
"https://www.apple.dk" & @CRLF & _
"https://www.fuckapple.dk" & @CRLF & _
"apple.dk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")