using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:www\.)?(?!apple\.)\b[A-Za-z-]*?apple[A-Za-z-]*\b(?:\.[A-Za-z]+)+$";
string input = @"badapple.com
https://fuckapple.dk
https://www.apple-sucks.co.uk
https://help.apple.com
support.apple.dk
fuck.apple.se
applesucks.fi
www.applesucks.fi
https://example-apple.com
my-apple-domain.net
apple-products.org
best-apple-deals.info
https://www.fresh-apple-pie.co.uk
juicyapplejuice.biz
https://apple-store-discount.ca
https://www.apple-store-discount.ca
www.apple.dk
apple.dk
https://apple.com
https://www.apple.dk
https://www.fuckapple.dk
apple.dk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}