import Foundation
let pattern = #"^(?:https?:\/\/)?(?:www\.)?(?!apple\.)\b[A-Za-z-]*?apple[A-Za-z-]*\b(?:\.[A-Za-z]+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
badapple.com
https://fuckapple.dk
https://www.apple-sucks.co.uk
https://help.apple.com
support.apple.dk
fuck.apple.se
applesucks.fi
www.applesucks.fi
https://example-apple.com
my-apple-domain.net
apple-products.org
best-apple-deals.info
https://www.fresh-apple-pie.co.uk
juicyapplejuice.biz
https://apple-store-discount.ca
https://www.apple-store-discount.ca
www.apple.dk
apple.dk
https://apple.com
https://www.apple.dk
https://www.fuckapple.dk
apple.dk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)