package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s:wlan (.+?)\s.+?dot1 authent (.+?)\n)`)
var str = `wlan SSID1 SSID1
test2
test1
dot1 authent TESTTEST1
test3
wlan SSID2 SSID2
test21
test11
test31
wlan SSID3 SSID3
test22
test12
dot1 authent TESTTEST3
test32
wlan SSID4 SSID4
test23
test13
dot1 authent TESTTEST4
test33
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}