// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s:wlan (.+?)\s.+?dot1 authent (.+?)\n)").unwrap();
let string = "wlan SSID1 SSID1
test2
test1
dot1 authent TESTTEST1
test3
wlan SSID2 SSID2
test21
test11
test31
wlan SSID3 SSID3
test22
test12
dot1 authent TESTTEST3
test32
wlan SSID4 SSID4
test23
test13
dot1 authent TESTTEST4
test33
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}