import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s:wlan (.+?)\\s.+?dot1 authent (.+?)\\n)";
final String string = "wlan SSID1 SSID1\n"
+ " test2\n"
+ " test1\n"
+ " dot1 authent TESTTEST1\n"
+ " test3\n"
+ "wlan SSID2 SSID2\n"
+ " test21\n"
+ " test11\n"
+ " test31\n"
+ "wlan SSID3 SSID3\n"
+ " test22\n"
+ " test12\n"
+ " dot1 authent TESTTEST3\n"
+ " test32\n"
+ "wlan SSID4 SSID4\n"
+ " test23\n"
+ " test13\n"
+ " dot1 authent TESTTEST4\n"
+ " test33\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}