$re = '/^(?:\[+(?\'id\'[0-9]+)?\]+)?(?\'name\'[^\[\.]+)?(?:\[+(?\'data\'[.\-:0-9 ]+)?\]+)?(?\'ext\'\.[.a-zA-Z]+)+/m';
$str = '[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
.zip
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);