re = /^(?:\[+(?'id'[0-9]+)?\]+)?(?'name'[^\[\.]+)?(?:\[+(?'data'[.\-:0-9 ]+)?\]+)?(?'ext'\.[.a-zA-Z]+)+/m
str = '[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
.zip
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end