import re
regex = re.compile(r"^(?:\[+(?'id'[0-9]+)?\]+)?(?'name'[^\[\.]+)?(?:\[+(?'data'[.\-:0-9 ]+)?\]+)?(?'ext'\.[.a-zA-Z]+)+", flags=re.MULTILINE)
test_str = ("[2013]Test1 [23.12.2020 13-34].zip\n"
"[2013]Test1 .zip\n"
"Test1 [23.12.2020 13-34].zip\n"
"Test1 .zip\n"
"[]Test1 [].zip\n"
"Te[]st[]1 .zip\n"
".zip\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")