import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{.+?\\})";
final String string = "cart = {\"note\\\":null,\\\"cart_level_discount_applications\\\":[]};\\n MAKEBECOOL_BUNDLES.product = {\"id\\\":7148755124373,\\\"title\\\":\\\"Couch Jumper White 6 Pack\\\",\\\"handle\\\":\\\"couch-jumper-white-6-pack\\\",\\\"description\\\":\\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, \"variants\": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}