// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)({.+?})").unwrap();
let string = "cart = {\"note\\\":null,\\\"cart_level_discount_applications\\\":[]};\\n MAKEBECOOL_BUNDLES.product = {\"id\\\":7148755124373,\\\"title\\\":\\\"Couch Jumper White 6 Pack\\\",\\\"handle\\\":\\\"couch-jumper-white-6-pack\\\",\\\"description\\\":\\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, \"variants\": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}