const regex = /({.+?})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({.+?})', 'gm')
const str = `cart = {"note\\":null,\\"cart_level_discount_applications\\":[]};\\n MAKEBECOOL_BUNDLES.product = {"id\\":7148755124373,\\"title\\":\\"Couch Jumper White 6 Pack\\",\\"handle\\":\\"couch-jumper-white-6-pack\\",\\"description\\":\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, "variants": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}