package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\/]+?\s((\w+\s)+?)\s*\w+?$`)
var str = `101 Main Street
2/b Pleasant Ave
333 The test Road
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}