$re = '/^[\w\/]+?\s((\w+\s)+?)\s*\w+?$/m';
$str = '101 Main Street
2/b Pleasant Ave
333 The test Road
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);