re = /^[\w\/]+?\s((\w+\s)+?)\s*\w+?$/m
str = '101 Main Street
2/b Pleasant Ave
333 The test Road
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end