using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$";
string input = @"1a2b3cd2312321
12q32131231231f
32132131231231231231221
aa
12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw
12222a22333fw342434234234weqweqw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}