import re
regex = re.compile(r"^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$", flags=re.MULTILINE)
test_str = ("1a2b3cd2312321\n"
"12q32131231231f\n"
"32132131231231231231221\n"
"aa\n"
"12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw\n"
"12222a22333fw342434234234weqweqw")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")