import re
regex = re.compile(r"/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$")
test_str = "example.com/img/fe5afe0482195afff9390692a6cc23e1"
subst = "/content/img/$1/$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)