use strict;
my $str = '02_01_fEa3129E_my Pic.png';
my $regex = qr/^([^_]+)_([^_]+)_/mp;
my $subst = '$1/$2/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";