$re = '/^([^_]+)_([^_]+)_/m';
$str = '02_01_fEa3129E_my Pic.png';
$subst = "$1/$2/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;