package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<ip>25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(.(?&ip)){3}$`)
var str = `123
1.2.3.4
1.2.3.4.
1.2.3.4.5
1..2.3.4
12.23.34.45
1.12.123.1234
192.168.23.56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}