$re = '/^(?<ip>25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(.(?&ip)){3}$/m';
$str = '123
1.2.3.4
1.2.3.4.
1.2.3.4.5
1..2.3.4
12.23.34.45
1.12.123.1234
192.168.23.56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);