import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<ip>25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(.(?&ip)){3}$";
final String string = "123\n"
+ "1.2.3.4\n"
+ "1.2.3.4.\n"
+ "1.2.3.4.5\n"
+ "1..2.3.4\n"
+ "12.23.34.45\n"
+ "1.12.123.1234\n"
+ "192.168.23.56";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}