#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(.*?)\s\d{6}\s\d{3}]\[\d]\[ERROR]"
Local $sString = "[02112017 072755 332][1][ERROR]> ----Message : IDC_NO_MEDIA" & @CRLF & _
"[02112017 072755 332][1][INFO]> ---- " & @CRLF & _
"[02112017 104502 724][1][ERROR]> ----Message : DEV_NOT_READY" & @CRLF & _
"[02112017 104502 724][1][INFO]> ---- " & @CRLF & _
"[02112017 104503 331][1][ERROR]> ----Message : DEV_NOT_READY" & @CRLF & _
"[02112017 104503 331][1][INFO]> ---- "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")