import re
regex = re.compile(r"^\[(.*?)\s\d{6}\s\d{3}]\[\d]\[ERROR]", flags=re.MULTILINE)
test_str = ("[02112017 072755 332][1][ERROR]> ----Message : IDC_NO_MEDIA\n"
"[02112017 072755 332][1][INFO]> ---- \n"
"[02112017 104502 724][1][ERROR]> ----Message : DEV_NOT_READY\n"
"[02112017 104502 724][1][INFO]> ---- \n"
"[02112017 104503 331][1][ERROR]> ----Message : DEV_NOT_READY\n"
"[02112017 104503 331][1][INFO]> ---- ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")