import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(.*?)\\s\\d{6}\\s\\d{3}]\\[\\d]\\[ERROR]";
final String string = "[02112017 072755 332][1][ERROR]> ----Message : IDC_NO_MEDIA\n"
+ "[02112017 072755 332][1][INFO]> ---- \n"
+ "[02112017 104502 724][1][ERROR]> ----Message : DEV_NOT_READY\n"
+ "[02112017 104502 724][1][INFO]> ---- \n"
+ "[02112017 104503 331][1][ERROR]> ----Message : DEV_NOT_READY\n"
+ "[02112017 104503 331][1][INFO]> ---- ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}