#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?:\s|^|\(|\[)(#[0-9]+)(?:\s|$|\)|\]|\.|\,(?:\s|$))"
Local $sString = "#1, #2, #3" & @CRLF & _
"#1 #2 #3 #4" & @CRLF & _
"(#1)(#2)(#3)" & @CRLF & _
""#1234"" & @CRLF & _
"#1234test" & @CRLF & _
"testme#3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")