// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)(?:\s|^|\(|\[)(#[0-9]+)(?:\s|$|\)|\]|\.|\,(?:\s|$))").unwrap();
let string = "#1, #2, #3
#1 #2 #3 #4
(#1)(#2)(#3)
\"#1234\"
#1234test
testme#3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}