$re = '`(?:\s|^|\(|\[)(#[0-9]+)(?:\s|$|\)|\]|\.|\,(?:\s|$))`sm';
$str = '#1, #2, #3
#1 #2 #3 #4
(#1)(#2)(#3)
"#1234"
#1234test
testme#3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);