#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:Pe(?:ng?)?|Gn(?:ep?)?)*(?:Peng|Gnep)$"
Local $sString = "Peng" & @CRLF & _
"Gnep" & @CRLF & _
"PengPeng" & @CRLF & _
"PenGnep" & @CRLF & _
"" & @CRLF & _
"Pooh" & @CRLF & _
"Pen" & @CRLF & _
"" & @CRLF & _
"PPeng" & @CRLF & _
"PengPe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")