package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:Pe(?:ng?)?|Gn(?:ep?)?)*(?:Peng|Gnep)$`)
var str = `Peng
Gnep
PengPeng
PenGnep
Pooh
Pen
PPeng
PengPe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}