$re = '/^(?:Pe(?:ng?)?|Gn(?:ep?)?)*(?:Peng|Gnep)$/m';
$str = 'Peng
Gnep
PengPeng
PenGnep
Pooh
Pen
PPeng
PengPe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);