import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})\\/((0[1-9])|(1[0-2]))\\/(0[1-9]|[12][0-9]|3[01])\\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]";
final String string = "[SNIPER-0096] [Attack_Name=(0075)HTTPD Overflow], [Time=2016/02/02 16:23:56], [Hacker=23.44.205.68], [Victim=103.247.220.153], [Protocol=tcp/80], [Risk=Medium], [Handling=Alarm], [Information=], [SrcPort=54179]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}