import Foundation
let pattern = #"(\d{4})\/((0[1-9])|(1[0-2]))\/(0[1-9]|[12][0-9]|3[01])\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[SNIPER-0096] [Attack_Name=(0075)HTTPD Overflow], [Time=2016/02/02 16:23:56], [Hacker=23.44.205.68], [Victim=103.247.220.153], [Protocol=tcp/80], [Risk=Medium], [Handling=Alarm], [Information=], [SrcPort=54179]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)