const regex = /(.+?")(.+?)(")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?")(.+?)(")', 'gm')
const str = `He said "test," then "again." and "oops"`;
const subst = `$2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);