re = /(.+?")(.+?)(")/m
str = 'He said "test," then "again." and "oops"'
subst = '$2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result