using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<id>[A-Za-z0-9_-]{1,185})::(?<ns>1220[a-f0-9]{64})$";
string input = @"alice::122004822c18c2484794f51361477817d5e943d49d5cb4d5c92a2f155b4c7c2e8928";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}