$re = '/^(?<id>[A-Za-z0-9_-]{1,185})::(?<ns>1220[a-f0-9]{64})$/m';
$str = 'alice::122004822c18c2484794f51361477817d5e943d49d5cb4d5c92a2f155b4c7c2e8928';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);