const regex = /^(?<id>[A-Za-z0-9_-]{1,185})::(?<ns>1220[a-f0-9]{64})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<id>[A-Za-z0-9_-]{1,185})::(?<ns>1220[a-f0-9]{64})$', 'gm')
const str = `alice::122004822c18c2484794f51361477817d5e943d49d5cb4d5c92a2f155b4c7c2e8928`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}